Strange – Index Creation Failed with a Windows backup

Issue

When performing a backup, the Report shows a Strange result.

In the DUMP SUMMARY a STRANGE DUMP is reported:

zmanda.com "C:/" lev 0 STRANGE (see below)

In the Notes field, the following error appears:

/-- zmanda.com "C:/" lev 0 STRANGE
sendbackup: start [zmanda.com:"C:/" level 0]
sendbackup: info BACKUP=pkzip
sendbackup: info RECOVER_CMD=Extract with zmanda windows client or unzip program
sendbackup: info end
| ZWC Backup ID: 5000
? Index creation failed
sendbackup: size 30000000
sendbackup: end
\--------

Cause

The Zmanda Windows Client uses an internal database to store the status of the backup or Index. This database must be in a good state for the storage of this information. If ZWC cannot save the data, it will report a strange error and that the Index creation failed. The most common cause of this error is a database crash from the root disk being full or from a Window crash.

Solution

To resolve this issue, the system must be in a good state with the root disk not full. After verifying there is free space on the drive, ZWC should be shut down.

To shut down ZWC:

As an Administrator user

  1. Bring up the Windows/Start Menu and type in Services
  2. Select the Services panel
  3. Scroll to the ZWC Service and right-click
  4. Select Stop

Once ZWC is stopped, the zwcrepair.bat batch file can be run:

As the Administrator user

  1. Bring up the Windows/Start Menu and type in cmd
  2. Right click on Command Prompt/cmd and select Run as Administrator
  3. Change directory into the ZWC Installation directory:
cd "C:\Program Files\Zmanda\Zmanda Client for Windows - Server Edition(x64)\bin"
  1. Run the zwcrepair.bat batch file:
zwcrepair.bat

Start the ZWC Service

As an Administrator user

  1. Bring up the Windows/Start Menu and type in Services
  2. Select the Services panel
  3. Scroll to the ZWC Service and right click
  4. Select Start